Апр 11 2016

blockДано: Mikrotik, VPN-сервер в далекой стране, нелегитимная блокировка провайдером сайта 2ip.ru и желание на него попасть.

Решение: Будем считать, что к vpn-серверу mikrotik уже подключен по интерфейсу vpn-usa.
Создаем список с именем vpn и добавляем в него заблокированный адрес:

/ip firewall address-list add address=178.63.151.224 list=vpn
Кстати, в графическом интерфейсе WinBox можно добавлять сайт не по IP, а по его имени:

mikrotik_vpn_list_add_item

Дальше — проще.
Добавляем NAT через vpn-подключение, добавляем еще один маршрут по умолчанию через интерфейс vpn-usa для пакетов с маркировкой vpn и указываем правило маркировки этих пакетов для IP-адресов из списка vpn:

/ip firewall nat add action=masquerade chain=srcnat out-interface=vpn-usa
/ip route add dst-address=0.0.0.0/0 gateway="vpn-usa" routing-mark=vpn
/ip firewall mangle add action=mark-routing chain=prerouting dst-address-list=vpn new-routing-mark=vpn passthrough=no

После этого открываем сайт 2ip.ru и видим, что сайт работает, а мы мгновенно переместились в пространстве.

2ip_usa

Полный профит и сбыча мечт 😉

Поделиться:

Автор: JohnnyТэги: , , , , , ,


One Response to “Открываем некоторые недоступные сайты через VPN на mikrotik”

  1. 1. Dimka Sharonoff Says:

    Роскомнадзор дополнил поправки в закон «Об информации…»: «зеркала» предложено приравнять к заблокированным сайтам, а за пропаганду средств обхода блокировки — ввести штрафы

    Подробнее на РБК:
    http://www.rbc.ru/technology_and_media/15/03/2016/56e81ccc9a7947aecd2679dd

Оставьте свой комментарий

Нужно войти в систему, чтобы оставлять комментарии.



Блог саратовского админа   

При использовании материалов сайта на других ресурсах прошу оставлять прямую ссылку на оригинал статьи.